Skip to main content
A
A
A
Banner of Health and Medical Research Fund

Level Double-A conformance, W3C WAI Web Content Accessibility Guidelines 2.1AA


eGMS FAQs
line

 

Frequently Asked Questions (FAQs)

Application for the Health and Medical Research Fund (HMRF)
via the Electronic Grant Management System (eGMS)

(A) General Information
(B) Login eGMS
(C) Application
(D) Project Monitoring (Applicable to investigator-initiated projects funded in 2012 application round and thereafter)
(E) Assessment of Grant Application or Final Report (For external reviewers)

Abbreviations

eGMS = electronic Grant Management System
HMRF = Health and Medical Research Fund
AI = Administering Institution
RO = Research Officer
FO = Finance Officer
EO = Executive Officer
DH = Department Head
RFS = Research Fund Secretariat
GRB = Grant Review Board
e-Form = electronic application form
Reviewers = external reviewers

 


(A) General Information

Access to eGMS


Training Manuals and User Guides

Application Project Monitoring

Demonstration

Application

Project Monitoring


Enquiries

 


(B) Login eGMS

Web address


Browser and system requirements

Google Chrome

(a)   We recommended eGMS user to use version 57 or above.  If you are using Google Chrome version 22 or above, TLS 1.1 is automatically supported.  TLS 1.1 and 1.2 are automatically enabled from version 29 or above.
(b)   To find out which version of google chrome you are using - chrome - 1 chrome - 2
  1. Open your Chrome browser.
  2. Click the “More” icon at the right corner of the address bar.
  3. At the bottom of the menu, click “Help”, then click “About Google Chrome”
  4. The version of Google Chrome will be shown.
(c)   To update Google Chrome:
  1. Chrome will check for any updates and immediately download them when you open the About Google Chrome page.
  2. Close your browser and restart Chrome to complete the update. chrome - 3

Mozilla Firefox

(a)   Set the TLS version of the browser:
  1. Open Firefox browser.
  2. In the address bar, type “about:config” and press “Enter”. firefox - 1
  3. In the Search field, enter “tls”.  Find and double-click the entry for “security.tls.version.max”.
    firefox - 2
  4. Set the integer value to 2 to force a minimum protocol of TLS 1.1.
  5. Set the integer value to 4 to force a maximum protocol of TLS 1.3.
    firefox - 3
  6. Click “OK”.
  7. Close your Firefox browser and restart your Firefox browser.
  8. Recommended version 51 or above.
    firefox - 4
(b)   To find out which version of Firefox browser you are using:
  1. Open Firefox browser.
  2. At the top of your Firefox browser, to the right of the address bar, click the “Menu” icon.
    firefox - 5
  3. At the bottom of the menu, click “Help”, then “About Firefox”.
  4. The version of Firefox browser will be shown.
    firefox - 6
    (Note: Updated version will be downloaded automatically)
    firefox - 7
  5. Close your browser and restart Firefox browser to complete the update.


Safari

There are no options for enabling SSL protocols.  If you are using Safari version 7 or above, TLS 1.2 is automatically enabled.


eGMS account (login email)



Youtube

To eGMS